Algoritmo "exerc1"



Baixar 22.29 Kb.
Encontro29.10.2017
Tamanho22.29 Kb.

  1. Em uma papelaria, até 100 folhas, a cópia custa R$0,25, e acima de 100 folhas custa R$0,20. Dado o total de cópias, informe o total a ser pago.

//1. Em uma papelaria, até 100 folhas, a cópia custa R$0,25, e acima de 100 folhas custa R$0,20. Dado o total de cópias, informe o total a ser pago.


algoritmo "exerc1"
var

numf: inteiro //numero de folhas

valor: real

inicio


escreva ("Digite o numero de folhas: ")

leia (numf)

se numf<=100 entao

valor <- numf* 0.25

senao

valor <- numf* 0.20



fimse

escreva ("Valor a Pagar: ", valor)

fimalgoritmo


  1. Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10.

//2. Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10.


algoritmo "exerc2"
var

num: inteiro //numero de folhas

inicio

escreva ("Digite um numero: ")



leia (num)

se num>10 entao

escreva("este numero é maior que 10")

senao


escreva("este numero não é maior que 10")

fimse


fimalgoritmo


  1. Faça um algoritmo que receba um número e diga se este número está no intervalo entre 100 e 200.

//3. Faça um algoritmo que receba um número e diga se este número está no intervalo entre 100 e 200.


algoritmo "exerc3"
var

num: inteiro //numero de folhas

inicio

escreva ("Digite um numero: ")



leia (num)

se (num>=100) e (num<=200) entao

escreva("Número dentro do intervalo")

senao


escreva("Número fora do intervalo")

fimse

fimalgoritmo


  1. Em uma fábrica, uma máquina precisa de manutenção sempre que o número de peças defeituosas supera 10% da produção. Dados o total de peças produzidas e o total de peças defeituosas, informe se a máquina precisa de manutenção.

//4. Em uma fábrica, uma máquina precisa de manutenção sempre que o número

//de peças defeituosas supera 10% da produção. Dados o total de peças produzidas

// e o total de peças defeituosas, informe se a máquina precisa de manutenção.

algoritmo "exerc4"
var

totpecas, totdef: inteiro

percdef: real

inicio


escreva ("Digite o total de peças: ")

leia (totpecas)

escreva ("Digite o total de peças defeituosas: ")

leia (totdef)

percdef <- totdef*100 / totpecas

se (percdef>10) entao

escreva("Máquina precisa de Manutenção")

senao


escreva("Máquina não precisa de Manutenção")

fimse

fimalgoritmo


  1. Dada a idade de um nadador, informe, informe a sua categoria: Infantil (até 10 anos), Juvenil (até 17 anos) ou Sênior (acima de 17 anos).

Exercício realizado em sala de aula.




  1. Dados três números distintos, exiba-os em ordem crescente.

//6. Dados três números distintos, exiba-os em ordem crescente.

algoritmo "exerc4"

var


a,b,c:inteiro

inicio


// Seção de Comandos

escreva("PRIMEIRO Nº ")

leia(a)

escreva("SEGUNDO Nº ")



leia(b)

escreva("TERCEIRO Nº ")

leia(c)
//111 – ok

se(a=b) e (a=c) e (b=c) entao

escreval("Todos são iguais")

fimse


//123 - ok

se(aa) e (c>b) entao

escreval(a,b,c)

fimse


//132 - ok

se(aa) e (b>c) entao

escreval(a,c,b)

fimse


//213 - ok

se(a>b) e (aa) entao

escreval(b,a,c)

fimse


//231 - ok

se(cc) e (b>a) entao

escreval(c,a,b)

fimse
//321 - ok

se(cc) entao

escreval(c,b,a)

fimse

//312 - ok



se(a>b) e (a>c) e (b

escreval(b,c,a)



fimse

fimalgoritmo

Baixar 22.29 Kb.

Compartilhe com seus amigos:




©bemvin.org 2020
enviar mensagem

    Página principal
Prefeitura municipal
santa catarina
Universidade federal
prefeitura municipal
pregão presencial
universidade federal
outras providências
processo seletivo
catarina prefeitura
minas gerais
secretaria municipal
CÂmara municipal
ensino fundamental
ensino médio
concurso público
catarina município
reunião ordinária
Dispõe sobre
Serviço público
câmara municipal
público federal
Processo seletivo
processo licitatório
educaçÃo universidade
seletivo simplificado
Secretaria municipal
sessão ordinária
ensino superior
Universidade estadual
Relatório técnico
Conselho municipal
técnico científico
direitos humanos
científico período
pregão eletrônico
Curriculum vitae
espírito santo
Sequência didática
Quarta feira
conselho municipal
prefeito municipal
distrito federal
língua portuguesa
nossa senhora
educaçÃo secretaria
Pregão presencial
segunda feira
recursos humanos
educaçÃO ciência
Terça feira
agricultura familiar